Несовпадение версий БД и ПО.

Учет доходов и расходов для УСН, ПСН и ЕСХН
voral
Сообщения: 5
Зарегистрирован: Пн, 26 апр 2010, 09:57

Несовпадение версий БД и ПО.

Непрочитанное сообщение voral » Пт, 03 сен 2010, 12:43

В виду "падения" программы. Установил свежескачанную версию. При запуске программа ругается на несовпадение версий. (При попытке обновить уже установленную было сообщение типа "непонятная версия программы обновить не могу")

Неплохо бы научить программу не просто сообщать о несовпадении, а сообщать какая именно версия БД и ПО. И вообще круто если научить подтягивать БД до последней версии.

Алексей
Администратор
Сообщения: 733
Зарегистрирован: Пт, 22 фев 2008, 20:45
Откуда: г. Луга
Контактная информация:

Re: Несовпадение версий БД и ПО.

Непрочитанное сообщение Алексей » Вт, 21 сен 2010, 01:06

voral писал(а):Неплохо бы научить программу не просто сообщать о несовпадении, а сообщать какая именно версия БД и ПО. И вообще круто если научить подтягивать БД до последней версии.
Этот вопрос решен при обновлениях программы (запуск дистрибутива).

savch
Сообщения: 2
Зарегистрирован: Пн, 28 янв 2013, 15:00

Непрочитанное сообщение savch » Пн, 28 янв 2013, 15:10

Вопрос по Книге доходов и расходов (несоотв. БД и ПО).
Здравствуйте, уважаемые сотрудники Луга-Софт!

Вот уже несколько лет пользуемся ПО "Книга доходов и расходов" (далее - КДиР) вашего авторства.
Подкупает простота интерфейса, высокая скорость работы, немонстроидальность.
Спасибо вам за ваш труд и верную расстановку приоритетов!

Проблем ни разу не было. Но... наступил 2013 :) год и случилась неприятность, хотя понимаю, что сами и виноваты.
Теперь смиренно прошу помощи. Изучение форума http://lugasoft.ru/forum/viewforum.php?f=13 ответа не дало.

Ситуация такова:
Версия КДиР: 2.0 от 20.10.10.
Версия БД : FB SQL Server 1.5. Была. И всё было хорошо.

Затем было куплено решение для GPS навигации.
После установки его клиентcкого ПО свойства FB сервера поменялись (обновилась версия до 2.1.4.18393) и КДиР стала выводить ошибку.

Каталог с программой КДиР был перенесён на другой ПК с аналогичной ОС (Win7 x64) и FB версией 1.5.5.4926.
Программа запустилась без проблем. Предположил посему, что данные в порядке, а причина ошибки - в несоответствии версий БД и ПО.

Вопрос:
Возможно-ли как-то вернуть функционал КДиР на "проблемном" ПК, есть поселилось другое ПО, также завязанное на FireBird?
Если да, прошу пояснить, что я должен предпринять?
Благодарю за ответ!

Алексей
Администратор
Сообщения: 733
Зарегистрирован: Пт, 22 фев 2008, 20:45
Откуда: г. Луга
Контактная информация:

Непрочитанное сообщение Алексей » Ср, 30 янв 2013, 02:17

Рассмотрите вариант установки ещё одной СУБД Firebird на другой порт. Например:
1. Скопируйте каталог FB версии 1.5.5.4926 на проблемный компьютер.
2. В каталоге FB на файл \BIN\fbserver.exe создайте ярлык. В свойствах ярлыка в поле "Объект" после fbserver.exe добавьте параметры "-a -p 3051".
3. Для программы подкорректируйте файл kniga.ini, например:
[DB]
Server=127.0.0.1/3051
Path=D:\Programs\LS-Kniga\2012\Levochkn\Data\Kniga.fdb
4. В реестре по ключу
HKEY_LOCAL_MACHINE\SOFTWARE\Firebird Project\Firebird Server\Instances
переименуйте Параметр "DefaultInstance" на "DefaultInstance1".
5. Запустите ярлык для fbserver.exe
6. Запустите все программы работающие с Firebird.
7. Если все нормально, добавьте созданный ярлык в автозагрузку, если нет, то обратно переименуйте параметр в реестре и верните в первоначальное состояние kniga.ini.

savch
Сообщения: 2
Зарегистрирован: Пн, 28 янв 2013, 15:00

Непрочитанное сообщение savch » Пт, 01 фев 2013, 15:27

Алексей писал(а):Рассмотрите вариант установки ещё одной СУБД Firebird на другой порт.
Алексей, спасибо! Применил описанный Вами метод и получилось! Пока работает!

Ответить